Accessibility
http://www.gadgetspeak.com/forum/group.rhtm

Misc

You need to login or register
to contribute to this forum
Anything not covered in other topics!
 Back to discussion list | Note : only members of this forum can post new messages
Started by
jonw
Posted Aug 17, 2005
At 12:06
Buffalo Air-Station WYR-G54 update
Since reviewing this product (and as a result of the review) someone kindly wrote in to give me the following link to updated firmware for the router. The link is :

    http://www.hornington.com/airstation/firmware/wyrv11r24.zip

I was a little nervous using this firmware because I couldn't get it (annoyingly) from buffalo and I couldn't work out the relationship between this site and Buffalo (anyone know).

In the end I took a chance and did the upgrade. Be aware: if you upgrade the firmware you loose your configuration, something I hadn't thought about! Back up the configuration using the web-interface before upgrading, then restore the old configuration.

Despite my nervousness the upgraded router does seem more stable. I now have firmware version 1.1, release 24, so something must have changed.

Disclaimer: I'm not suggesting everyone upgrade using this firmware. I'm pretty siure it's unsupported by Buffalo and has probably invalidated my warrenty (haven't checked!). It worked for me :-)

Replies to this discussion Total Responses:19
Posted Dec 14, 2006
At 10:24
New firmware(Reply 8)

hi there.found a new version,release 02-Nov.-06

http://www.buffalo-asia.com/file/download/WYR-G54_1.402.zip

Please tell me the changes beacuse the router is at my sister ,200km from home and i do not want to make an upgrade from here to mess everything up.

Posted Jan 31, 2007
At 9:24
New firmware(Reply 9)
I just tried this latest firmware version 1.402, updating the WYR-G54 Japanese v1.4 firmware. It works fine. It is in English and it kept all the settings I have previously made on the earlier version.
Posted May 16, 2008
At 21:29
WYR-G54 upgraded using Planex BLW-54PM firmware...(Reply 10)

Hi -- I was about to toss out my WYR-G54 after its wireless support started flaking out and not finding any firmware upgrades beyond 1.402.  However, after some desparate Googling I discovered an interesting post from japan claiming that the WYR-G54 has the same internals as some other OEM devices, namely the BLW-54PM from Planex...

http://raijo.aa0.netvolante.jp/computer/wyr_g54/

http://translate.google.com/translate?u=http%3A%2F%2Fraijo.aa0.netvolante.jp%2Fcomputer%2Fwyr_g54&sl=ja&tl=en

I EXPECTED to totally brick my device by following the roughly translated instructions, but instead am pleased to report that my device now believes it's a BLW-54PM version 3.000 firmware Planex unit!

The wireless seems much more robust than before and the Planex web UI supports some formerly inaccessible options (like manually adding MAC addresses for access/routing). The rest of the web interface has a different theme but is essentially the same -- you can preview it in the PDF manual from Planex (same link as below). That's actually how I (informally) validated the possibility that these two devices are siblings.

So, if you have an old WYR-G54, and you don't mind potentially killing it, the process I used was:

** DO NOT APPLY THIS UPGRADE IF YOU ARE NOT PREPARED TO BRICK (render useless) YOUR ROUTER. **

  1. Download WYR-G54_1.402.zip (the link in earlier post above still worked as of today)
  2. Download Planex BLW-54PM v3.000 firmware from: http://www.planex.net/download/router/blw-54pm.htm
  3. Extract both firmware .IMG files (WYR-G54_Eng_1402.img, BLW-54PM_Firmware_PCI_ENG_v3000.img). Write down the freshly extracted v3000.img file size -- in bytes (mine was 720311).
  4. Use a hex editor to exactly clone (overwrite not insert) the first 52 bytes and the last 40 bytes from the WYR image to the BLW image.  I used KHexEdit on linux, but you should be able to find a hex editor for any platform via google. Note that the last 40 bytes will _start_ at a different location in each file, so be sure to work backwards from the end of each file individually when cloning those.
  5. (not sure if this is needed): I saw "14 02" at offset 50 and also in the last 40 bytes of the WYR, along with "30 00" in the same locations in the BLW image, so assumed these were version markers.  After cloning the WYR bytes over with "14 02" I then changed them both to be "14 03" (in case maybe the router consider this before upgrading).
  6. Save the resulting image as something memorable, I used "WYR1403.img". As a high level check, make sure the original v3000 firmware and your transplanted image are exactly the same file size -- if not the clone procedure removed or added bytes which is wrong so try again.  For reference, with the #5 version change the md5sum of my image was: 7023cbc9946be3eb444ade76a3f82e57
  7. Backup your config settings (admcfg.cfg) and purchase a backup router and/or have a contigency plan ready (remember this could totally brick your device!)
  8. (optional -- not sure if really needed) Reset your device to factory defaults
  9. Connect via cat5 and upgrade your WYR-G54 using the standard web UI and your new image.
  10. cross your fingers, let the firmware screen finish loading, and see if it worked!

NOTE: I did not reset my device to factory defaults before upgrading, but in hindsight it might have been a good idea. Looking at the saved config files (admcfg.cfg) before and after the upgrade, only a handful seem to mesh up -- for example, it kept my admin password but none of the LAN or access point settings

The BLW-54PM docs say the factory admin login is a blank username and "0000" (four zeros) for the password, but as mentioned it actually kept my admin password so my login was blank username and my old password at 192.168.2.1 (vs. "root" before).

Good luck to anyone else daring enough to try this! ;)

Best regards,

-Tim

Posted May 31, 2008
At 12:09
Buffalo Air-Station WYR-G54 update(Reply 11)

Thanks for the instructions, Tim. Now my old WYR-G54 has a much improved web interface and a few extra features. (Hiding SSID, bug-free client monitor/manager, and MTU control are some that stand out.) Here are a few notes from my experience, which might help others:

  1. If the router has a different ip address from factory default now, remember the address will reset to 192.168.1.1. (Not 192.168.2.1 as Tim mentioned above.) I had a few disappointed moments believing that I messed up the process, when the router web control became unresponsive. Luckily I had downloaded the BLW-54PM manual, which mentions the default IP. Furthermore, I had to renew my computer connection (ipconfig /release, ipconfig /renew in cmd prompt) to get on the new address.
  2. DO NOT reload the old config. For some reason this caused confusion to the router login process. Because I had a bunch of settings I wanted to retain, I loaded the old config to recover them. After this, I could not log back into the router. I suspect the old firmware has "root" as the login name, whereas the new firmware does not ask for one. In the old config, I noticed "root" was mentioned. I had to reset the router (via the little button on the back) and used the default password Tim mentioned. To recover the old settings successfully, I get a new config and edited the relevant section based on info from the old. It is a fiddly proces, but the two files follow the same format. Most of my old settings survived the edit, although I had to review and reenter the target computers in address routing table, which is now called the virtual servers table.
  3. I used the hex editor HxD on Windows. Not sure if it is the best, but it is free and did the job.
  4. Thanks again, Tim, for the information about this firmware.

    By the way, have anyone tried this hack, which supposedly would give WPA2-PSK and AES encryption capability to the BLW-54PM router. http://byfai.com/node/33/ I am really tempted, despite the lack of good instructions like the ones Tim gave, but I need a rest after the recent ordeal. :-)

Posted June 1, 2008
At 2:54
Possible To Upload Firmware?(Reply 12)

As I am not as smart as you guys I was wondering if it would be possible to upload the changed Planex Firmware for the WYR-G54 or possibly send it to me if the file is small enough. ([email protected]*tmail.c*m)


Thanks in Advance


James

Posted June 24, 2008
At 15:37
Help, please!(Reply 13)

I just got a chance to do it. I modified the image and update the router's firmware. http://fileserver0002.googlepages.com/BLW-54PM_Firmware_PCI_ENG_v3000mod


Everything is fine except I cannot access the internet. I ran setup wizard and it said the connection is OK. When I go to the status page, I got everything is okay. (Is it normal for it to display IP address as  192.168.1 .95?) But I cannot use firefox or ie to access the internet.

So I have to reflash the router back to 14.02. 


Do you guys know why it acts the way it does?

Only members can contribute

You have to be logged into the site before you can participate in the disussion.

Member login

Welcome back to GadgetSpeak.

:
:

Not a member? Why not join?

lost password?